Не работает отправка копии e-mail себе

Клиент обратился с проблемой, что в УНФ не работает отправка коии писем себе. В УНФ можно посмотреть отправленные письма, но УНФ не всегда под рукой, хотелось бы видеть отправленные письма у себя в почтовом ящике.

При этом настройка отправки копии писем стоит:

Запускаю поиск ОтправлятьСкрытыеКопииПисемНаЭтотАдрес, вхождений немного, в каждом из них ставлю точку останова:

Захожу в События — Письма, создаю новое письмо себе:

Но мои точки останова не срабатывают, потому что отправка писем происходит в фоновом режиме, видимо. Поэтому включаю режим отладки.

Но это не поогает, включаю замер производительности и по нему обнаруживаю, что письмо отправляется совсем в другом месте:

Вы понимаете? УНФ использует свой движок отправки писем, но не поддерживает типовую галочку. Это ошибка!

Ну что же, сделаем сами. За основу беру типовой код по отправке писем:

Расширяю модуль ЭлектроннаяПочтаУНФ, немного перерабатываю исходный код (раз 5 менял код и прогонял, у меня было много ошибок):

&Вместо("ОтправитьПочтовоеСообщение")
Функция ТР_ОтправитьПочтовоеСообщение(Знач ПараметрыПисьма, Знач УчетнаяЗапись)
	
	//Если учетная запись указана
	Если ТипЗнч(УчетнаяЗапись) = Тип("СправочникСсылка.УчетныеЗаписиЭлектроннойПочты")
		И ЗначениеЗаполнено(УчетнаяЗапись) Тогда                                      
		
		//Копируем код из модуля РаботаСПочтовымиСообщениямиСлужебный.ОтправитьСообщение
		Если УчетнаяЗапись.ОтправлятьСкрытыеКопииПисемНаЭтотАдрес Тогда
			М = Новый Массив();
			М.Добавить(Новый Структура("Адрес, Представление", УчетнаяЗапись.АдресЭлектроннойПочты, УчетнаяЗапись.ИмяПользователя));
			ПараметрыПисьма.Вставить("СлепыеКопии", М); 
		КонецЕсли;

		
	КонецЕсли;

	
	Результат = ПродолжитьВызов(ПараметрыПисьма, УчетнаяЗапись);
	Возврат Результат; 
	
КонецФункции

Делаю еще раз тестовую отправку, уточняю у пользователя, пришло ли ему письмо с копией.

Меня в этой задаче заинтриговало также, чем слепые копии отличаются от скрытых. Оказалось, что просто кто-то раньше называл их скрытыми, и это используется для совместимости. В 1С есть только слепые копии (Bcc):

Среда: УНФ 1.6.26.172. Объем: 1 час.

fixin

Программирую на 1С с 1999 года. В 1С просто Гений. В 2020 году ушел из офиса на вольные хлеба фриланса. Принимаю заказы.

Читайте также:

Добавить комментарий

Ваш адрес email не будет опубликован.