Отключаем рекламу 1С в выписках и ведомостях в банк БП3

Клиент жалуется, что в формах 1С показывается навязчивая реклама:

Форма: e1cib/command/ЖурналДокументов.Деньги.Команда.БанковскиеВыписки

Форма: e1cib/list/Документ.ВедомостьНаВыплатуЗарплатыВБанк

Показывать или нет рекламу определяется в функции ВидимостьЭлементовДиректБанк модуля БанковскиеВыписки

Настройка в хранилище заносится здесь:

Настройки сохраняются, когда пользователь закрывает крестиком окно рекламы, но потом восстанавливаются видимо.

Поэтому принято решение отключать рекламу с помощью расширения модуля ЭлектронноеВзаимодействиеБПВызовСервера:

&Вместо("ВидимостьЭлементовДиректБанк")
Функция нр1с_ВидимостьЭлементовДиректБанк(Организация, ДанныеБанкаСчета)
	// Вставить содержимое метода.
	Результат = ПродолжитьВызов(Организация, ДанныеБанкаСчета);
	Если Результат = "ПоказатьБаннер" Тогда
		Возврат "ПоказатьГиперссылку";
	КонецЕсли;
	Возврат Результат;
КонецФункции

На самом деле этого мало, реклама все равно показывается, нужно еще перекрыть модуль ПерсонализированныеПредложенияСервисов:

&Вместо("УстановитьБаннерНаФорме")
Процедура нр1с_УстановитьБаннерНаФорме(Форма, АдресРезультата)
	
	Если Форма.Элементы.Найти("Баннер") <> неопределено Тогда
		Форма.Элементы.Баннер.Видимость = ложь;
		Возврат;
	КонецЕсли;                              
	
	ПродолжитьВызов(Форма, АдресРезультата);
КонецПроцедуры

Это отключает рекламу в выписках, чтобы отключить в ведомостях на выплату зарплаты через банк нужно отключить еще в модуле ОбменСБанками:

&Вместо("ДобавитьРекламу")
Процедура нр1с_ДобавитьРекламу(ФормаОбъект, Параметры)
	Возврат; 
	
	ПродолжитьВызов(ФормаОбъект, Параметры);
КонецПроцедуры

Ну и чтобы дважды не ходить, отключаем информацию при запуске расширяя форму ИнформацияПриЗапуске (обязательно перед созданием, т.к. после нельзя отказ делать):

&НаСервере
Процедура нр1с_ПриСозданииНаСервереПеред(Отказ, СтандартнаяОбработка)
	//Отключаем
	Отказ = истина;
КонецПроцедуры

Нужно обязательно снять галочку «Безопасный режим», иначе расширение модулей не сработает.

Среда: Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.107.37)
Объем: 0.8 час.

fixin

Программирую на 1С с 1999 года. В 1С просто Гений. В 2020 году ушел из офиса на вольные хлеба фриланса. Принимаю заказы.

Читайте также:

комментария 2

  1. василиса:

    у вас все так сложно.. Изменить форму — убираем галку «баннер»…

    • а при повторном открытии формы работает?
      в любом случае проще один раз написать расширение и давать его всем пользователям, чем рассылать инструкции.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *